MFA with DUO fails to create JIT Rule

Incident Report for Zero Networks

Resolved

Zero Networks pushed a fix yesterday at 17:00 (UTC) that fully resolves our MFA with DUO.
We've monitored it for over 12 hours to confirm everything is working as expected.
Incident resolved.
Posted Apr 10, 2025 - 07:21 UTC

Update

We are continuing to monitor for any further issues.
Posted Apr 08, 2025 - 16:41 UTC

Monitoring

Issue seems to reside on Duo's side - We see issues getting responses to our requests. We've added timeouts from our side to better handle those requests.
Temporary workaround: Using browser-based MFA.
Posted Apr 08, 2025 - 16:33 UTC

Investigating

We are currently experiencing an issue where Duo push notifications, once approved, are not immediately triggering the creation of the corresponding JIT access rule in the portal.

As a temporary solution, we recommend using alternative MFA methods such as browser-based MFA.
Posted Apr 08, 2025 - 15:49 UTC
This incident affected: MFA.