Performance Degradation in Cloud Services

Incident Report for Zero Networks

Resolved

This incident has been resolved.
Posted Apr 30, 2026 - 00:32 UTC

Update

We are continuing to monitor for any further issues.
Posted Apr 29, 2026 - 20:19 UTC

Update

We are continuing to monitor for any further issues.
Posted Apr 29, 2026 - 18:30 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 29, 2026 - 18:21 UTC

Investigating

We are currently experiencing a performance degradation affecting our Cloud Services, resulting in portal slowness and intermittent MFA delays. Our team is actively investigating, and we will provide an update as soon as more information is available.
Posted Apr 29, 2026 - 18:05 UTC
This incident affected: Portal Access and MFA.